vue-cli-service 不是内部或外部命令 一行命令解决

nodejs 文章 2020-07-31 17:13 0 52 全屏看文

今天在vscode里又遇到了“vue-cli-service 不是内部或外部命令”的提示。

百度里找了一堆文章都找不到。

最后只好问同事,给了一行命令搞定的。

npm install -g @vue/cli

运行后控制台输出

npm install -g @vue/cli
npm WARN deprecated @hapi/joi@15.1.1: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/address@2.1.4: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
C:\Users\admin\AppData\Roaming\npm\vue -> C:\Users\admin\AppData\Roaming\npm\node_modules\@vue\cli\bin\vue.js
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\@vue\cli\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ @vue/cli@4.4.6
added 111 packages from 44 contributors, removed 52 packages, updated 199 packages and moved 7 packages in 263.255s


-EOF-